Upgrading node and yarn

Problem

You are getting the following error when trying to use yarn:

Solution

Upgrade yarn

Which should give the updated yarn version:

Upgrade node version with the correct version from above (ie 10.0.0)

And then the needed versions would have been installed:

Error: Brunch 2+ requires node v4.0+. Upgrade node or use older brunch for old node.js: npm i -g brunch@1

Problem

Trying to start a new phoenix application while your node installation is old you get the following error:

Solution

You will need to upgrade your node installation by following the steps below: