You are trying to upgrade one of your gems (ie uglifier) and at the same time you are using a new gemset (ie for rails 4.2.4), and you get the following error when you are trying to bundle:
Could not find libv8-126.96.36.199 in any of the sources
Upgrade to rails 4.2.4 first and bundle and afterwards change the other gem and do bundle again.
You are getting a libv8 installation error in a new rails 4.0 application in an older linux installation
An error occurred while installing libv8 (188.8.131.52), and Bundler cannot continue.
Make sure that `gem install libv8 -v '184.108.40.206'` succeeds before bundling.
This is causes by the latest gem version of the therubyracer dependency on the libv8.
You can get over it by specifying version 0.11.4 for the gem as in:
gem 'therubyracer', '~> 0.11.4', platforms: :ruby
and then running bundle install again.