Could not find activesupport-3.0.12 in any of the sources (Bundler::GemNotFound)


You are trying to update your rails app deployed on a server, for example from 3.0.11 to 3.0.12, and at the same time trying to update the Ruby version from 1.9.2 to 1.9.3 but you are getting the following error from passenger:

and then modify the apache configuration file as in:

and then reload your apache configuration

Creating a Vagrant Box with Debian Lenny 32, rvm and Ruby 1.9.3

As an addition to the excellent beta book ‘Deploying Rails’, as I had problems using the suggested lucid64 image, I’ve tried to install a debian lenny 32 image with rvm and Ruby 1.9.3.

The steps needed are listed below


  1. Download the lenny package:
  2. Make a new directory for the virtual box:
  3. change into created directory and create the Vagrant file:
  4. change the Vagrant file to use the virtual box we have downloaded:
  5. Start the VM:
  6. If there is a warning about the Guest additions here install the latest guest additions by following the description here, but only use the update and upgrade steps as:
  7. After finishing the upgrade logout (exit) from the VM and issue the command to restart the VM:
  8. login to the VM again:

  9. Download and install rvm by using the script described here :
  10. Add the loading of the RVM function into .bashrc, by running the following in the command prompt:
  11. Reload the bashrc file:
  12. Make sure that the rvm is loaded as function:
  13. Run the rvm requirement to see the needed libraries and then run the suggested ones (except libreadline6 and libreadline6-dev that are not there in debian):
  14. Install Ruby 1.9.3 :
  15. Use the ruby 1.9.3 as default:
  16. Finally create a new VM package to use in future:
  17. And add it our box list:

cannot load such file — zlib


You are trying to install a gem with rvm but you are getting the following error:

ERROR: Loading command: install (LoadError
cannot load such file — zlib
ERROR: While executing gem … (NameError)
uninitialized constant Gem::Commands::InstallCommand


Following from the post here

you would need to install the zlib library with rvm, uninstall your ruby version and then install the ruby version again with the folowing: