assert_difference and Rails 2.1.0

Problem
Trying to use the assert_difference with Rails 2.1.0 produces errors if trying to use it with the syntax of another rails version.

Solution
The correct syntax for using assert_difference with rails 2.1.0 is: